Return to Gnome Classic in Ubuntu 12.04 (Precise Pangolin) 5


This brief tutorial shows you how to switch your Unity Desktop to classic Gnome Classic in Ubuntu 12.04. As you may well know, Ubuntu comes with Unity Desktop by default and fallback to Unity 2D if your graphic card isn’t capable of running the 3D version of Unity. Now, if Unity is not what you’re used to, you can still switch your desktop session to the classic Gnome Desktop easily by running just one command. And to do that, just continue below to learn how.

Objectives:

  • Install Gnome Classic Desktop in Ubuntu 12.04
  • Enjoy!

To get started, press Ctrl – Alt – T on your keyboard to open Terminal. When it opens, run the commands below to enable Gnome Classic.

sudo apt-get install gnome-session-fallback

 

precise_fallback

 

Restart and on the logon screen, click the option to change your session.

 

precise_fallback_1

 

Then choose Gnome Classic to logon.

 

precise_fallback_2

 

Enjoy your classic desktop.

 

precise_fallback_3

 

To add applications to the top panel, hold-down the Alt key and right-click on the panel.

 

precise_fallback_4

 

That’s it! You shouldn’t always have to select Gnome Classic from the logon screen before logging in. Once you’ve select a desktop session, it will stay your session until you switches to another.


Please share if you like it on:



Leave a Comment

Your email address will not be published. Required fields are marked *

5 thoughts on “Return to Gnome Classic in Ubuntu 12.04 (Precise Pangolin)

  • Don S

    Thanks — I like the Unity desktop just fine (which somewhat invalidates my hatred of win 8, I suppose, since I use Unity by hiding the app bar and using a mouse movement to display it) but it’s good to have the option of another desktop.

  • Tommy

    Didn’t work for me. I get
    *******************************
    The following packages have unmet dependencies:
    gnome-session-fallback : Depends: gnome-panel (>= 3.0) but it is not going to be installed
    libxml-libxml-perl : Depends: perlapi-5.10.0 but it is not installable
    Depends: libxml-sax-perl but it is not going to be installed
    E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).
    ********************************
    And if I then do
    sudo apt-get -f install
    all I get is
    ********************************
    /var/lib/dpkg/info/libxml-libxml-perl.prerm: 11: /var/lib/dpkg/info/libxml-libxml-perl.prerm: update-perl-sax-parsers: not found
    dpkg: error processing libxml-libxml-perl (–remove):
    subprocess installed pre-removal script returned error exit status 127
    Errors were encountered while processing: libxml-libxml-perl
    E: Sub-process /usr/bin/dpkg returned an error code (1)