Fix the Package System is Broken error in Ubuntu 10.04/10.10 Maverick Meerkat 3


This brief tutorial will show you how to fix ‘The package system is broken’ error in Ubuntu Lucid or Maverick. Sometimes when you’re installing programs in Ubuntu and all dependencies are not installed, your package system would get corrupted and you won’t be able install new programs or packages. This will help you fix that.

 

Getting started:

 

Below is the image of the error you’ll get when your package system is broken.

 

broken_package_mav

 

To fix it, go to System –> Administration –> Synaptic Package Manager.

 

broken_package_mav-1

 

Then select ‘Custom Filters’ on the left menu.

 

broken_package_mav-2

 

Next select ‘Broken’ on the left and you’ll then notice package(s) with the red exclamation marks.

 

broken_package_mav-3 

 

Right-click each package and select ‘Mark for Complete Removal’.

 

broken_package_mav-4

 

Then click ‘Apply’ to apply the change. When prompted again, click ‘Apply’ to remove them.

 

broken_package_mav-5

 

Enjoy!

 

broken_package_mav-6

 

Thanks for reading and please come back soon.


Please share if you like it on:



Leave a Comment

Your email address will not be published. Required fields are marked *

3 thoughts on “Fix the Package System is Broken error in Ubuntu 10.04/10.10 Maverick Meerkat